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What is Math?

Math is LibreOffice’s component for writing mathematical and chemical equations. It is most 
commonly used as an equation editor for text documents, but it can also be used with other types 
of documents or stand-alone. When used inside Writer, the equation is treated as an object inside 
the text document.

Note
The equation editor is for writing equations in symbolic form, as in equation 1, below. 
If you want to evaluate a numeric value, see the Calc Guide.

df (x )
dx

=ln(x )+ tan−1(x2) (1)

or

  NH3+H2 O⇌NH4
++OH−

Getting started

You can create an equation (formula) as a separate document or insert it into a document in Writer 
or another component of LibreOffice.

Creating an equation as a separate document
To create an equation as a separate document, open the Math component of LibreOffice using one
of these methods:

• On the Menu bar, choose File > New > Formula.

• On the Standard Toolbar, click the triangle to the right of the New icon and choose 
Formula.

• From the Start Center, click Math Formula.

An empty Math document opens (see Figure 1).

Figure 1: An empty Math document

Getting started 5



The upper area on the right is the preview window, where the equation will appear during and 
after input. The lower area on the right is the equation editor, where the markup code for the 
equation is entered. On the left is the Elements Dock.

Inserting a formula into a Writer document
To insert a formula into a Writer document, open the document and then choose Insert > Object > 
Formula from the Menu bar.

The formula editor opens at the bottom of the Writer window. You will also see a small box with a 
gray border in your document, where the formula will be displayed. Depending on your setup, the 
Elements Dock or the Elements window may also appear.

When you are done entering the formula, you can close the editor by pressing the Esc key or by 
clicking an area outside the formula in the main document. A double-click on the box will open the 
editor again, so you can edit the formula.

Formulas are inserted as OLE objects. In a Writer document, the formula is anchored as a 
character, so it is embedded in the continuous text. You can, as with any other OLE object, change 
the anchor and make the formula floating. In Calc, Impress and Draw documents, formulas are 
embedded as floating OLE objects.

If you frequently need to insert formulas, you may wish to add the Formula button to the Standard 
toolbar or create a keyboard shortcut. See Chapter 14, Customizing LibreOffice, for more 
information.

Entering a formula

The equation editor uses a markup language to represent formulas. For example, %beta creates 
the Greek character beta ( β ). This markup is designed to read similar to English whenever 

possible. For example, a over b produces a fraction: 
a
b

.

You can enter a formula in three ways:

• Select a symbol from the Elements Dock or Elements window.

• Right-click on the equation editor and select the symbol from the context menu.

• Type markup in the equation editor.

The context menu, the Elements Dock, and the Elements window all insert the markup 
corresponding to a symbol. This provides a convenient way to learn the LibreOffice Math markup.

Note
Click on the document body to exit the formula editor.

Double-click on a formula to enter the formula editor again.

Elements Dock
The simplest method for entering a formula is by using Elements. By default, an Elements Dock is 
visible at the left of the equation editor when first opening Math. If a greater area is needed to 
display the preview window or equation editor, the Elements Dock can be hidden with View > 
Elements Dock.

The Elements Dock is divided into two main parts.

• The drop-down list at the top of the Dock shows symbol categories.

• The symbols are displayed beneath the drop-down list.  These symbols change according 
to the category selected.
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Figure 2:Selecting a category in the Elements Dock

Example 1: 5×4

For this example we will enter a simple formula: 5×4 . On the Elements Dock:

1) Ensure the Unary/Binary Operators category is selected in the drop-down list (see Figure 
2).

2) Click the multiplication symbol (see Figure 3).

Figure 3: Selecting the multiplication symbol

When you select the multiplication symbol, two things happen:

• The equation editor shows the markup: <?> times <?>

• The body of the document shows a gray box like this: ❑×❑
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Figure 4: Result of selecting the multiplication symbol

The <?> symbols shown in Figure 4 are placeholders that you can replace by other text, for 
example 5 and 4. The equation will update automatically, as shown in Figure 5.

Tip
When you add a formula, reserved placeholders are indicated by squares in the 
formula and <?> in the command window. You can navigate through these 
placeholders using F4 and Shift+F4.

Tip
To keep the equation from updating automatically, select View > AutoUpdate display 
to deselect it. To update a formula manually, press F9 or select View > Update.

Figure 5: Result of entering 5 and 4 next to the times operator

Elements window
Elements can also be accessed in a separate floating window.  To display the Elements window, go
to View > Elements.

The Elements window operates in a similar manner to the Elements Dock and is also divided into 
two main parts (see Figure 6).

• The upper area shows the symbol categories. Click on these to change the list of symbols.

• The lower area shows the symbols available in the current category.
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Figure 6: The Elements window

Right-click (context) menu
Another way to access mathematical symbols is to right-click on the equation editor. This pops up 
the menu shown in Figure 7. The items in this menu correspond to those in the Elements window, 
with some extra commands.

Figure 7: Right-click (context) menu

Note
Neither the window elements, nor the context menu contain a complete list of 
commands. For some seldom-used commands, you must always enter the markup. 
A complete list of commands can be found in the appendix of the Math Guide.
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Markup
You can type the markup directly in the equation editor. For example, you can type 5 times 4 to 
obtain 5×4 . If you know the markup, this can be the fastest way to enter a formula.

Tip The formula markup resembles the way the formula reads in English.

Below is a short list of common equations and their corresponding markup.

Display Command Display Command

a=b a = b √ a sqrt {a}

a2 a^2 an a_n

∫ f (x )dx int f(x) dx ∑ an
sum a_n

a≤b a <= b ∞ infinity

a×b a times b x⋅y x cdot y

Greek characters
Greek characters ( α ,β ,γ ,θ , etc) are common in mathematical formulas. These characters are 
not available in the Elements window or the right-click menu. Fortunately, the markup for Greek 
characters is simple: Type a % sign followed by the name of the character, in English.

• To write a lowercase character, type the name of the character in lowercase.

• To write an uppercase character, type the name of the character in uppercase.

•  To write in italic, just add an i between the % sign and the name of the character.

A complete table of Greek characters is provided in the appendix of the Math Guide. See the table 
below for some examples.

Lowercase Uppercase Italic lowercase Italic uppercase

%alpha → α %ALPHA → Α %ialpha → α %iALPHA → Α

%beta → β %BETA → Β %ibeta → β %iBETA → Β

%gamma → γ %GAMMA → Γ %igamma → γ %iGAMMA → Γ

%psi  → ψ %PSI  → Ψ %ipsi  → ψ %iPSI  → Ψ

%phi  → ϕ %PHI  → Φ %iphi  → ϕ %iPHI  → Φ

%theta → θ %THETA → Θ %itheta → θ %iTHETA → Θ

Another way to enter Greek characters is by using the Symbols catalog window. Choose Tools > 
Catalog. This window is shown in Figure 8. Under Symbol set, select Greek and double-click on a 
Greek letter from the list. The markup name of the character is shown below the list window.
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Figure 8: Symbols catalog, used for entering Greek characters and special symbols

Example 2: π ≃ 3.14159

For this example we will suppose that:

• We want to enter the above formula (the value of pi rounded to 5 decimal places).

• We know the name of the Greek character (pi).

• But we do not know the markup associated with the ≃  symbol.

Step 1: Type % followed by the text pi. This displays the Greek character π .

Step 2: Open the Elements window (View > Elements).

Step 3: The ≃  symbol is a relation, so we click on the Relations button. If you hover the mouse 
over this button you see the tooltip Relations (Figure 9).

Figure 10 shows the Elements window after clicking the Relations button. The symbol we want is 
circled.

Figure 9: Tooltip indicates the 
Relations button

Figure 10: After selecting Relations

Step 4: Click on the a ≃ b symbol. The equation editor now shows the markup
%pi<?> simeq <?>.

Step 5: Delete the first <?> text, then press the F4 key to move to the next <?> entry. Type 
3.14159 to replace the <?> at the end of the equation. We end up with the markup %pi simeq 
3.14159. The result is shown in Figure 11.
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Figure 11: Final result

Changing a formula
You can change a formula at any time. To switch into edit mode, double-click on the formula.

To get to the appropriate section in the markup code, do any one of the following:

• In the equation editor, click on the location.

• Select an area of the markup code that you wish to change.

• Click on an element in the preview area; the cursor will automatically move to the 
corresponding point in the equation editor.

• Double-click on an element in the preview area; the corresponding section in the equation 
editor will be selected.

To be able to work in the upper (preview) area in the stand-alone Math window (Figure 1), the 
formula cursor must be activated. Use the Formula Cursor button on the Tools toolbar.

You can change an equation by overwriting selected text or by inserting new markup code at the 
cursor position.

Formula layout

The most difficult part of using LibreOffice Math comes when writing complicated formulas. This 
section provides some advice.

Brackets 
Math knows nothing about order of operation. You must use brackets to state the order of 
operations explicitly. Consider the following examples.

Markup Result Markup Result

2 over x + 1
2
x
+1 2 over {x + 1}

2
x+1

– 1 over 2   
−1
2

– {1 over 2}   −
1
2
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In the first example, Math has recognized that the 2 before and the x after the over belong to the 
fraction, and has represented them accordingly. If you want x+1 rather than x to be the 
denominator, you must bracket them together so that both will be placed there.

In the second example, Math has recognized the minus sign as a prefix for the 1 and has therefore
placed it in the numerator of the fraction. If you wish to show that the whole thing is negative, with 
the minus sign in front of the fraction, you must put the fraction in brackets in order to signify to 
Math that the characters belong together.

The braces belong solely to the layout of the markup code and are not printed. If you wish to use 
braces in the formula, use the commands lbrace and rbrace.

Compare the following examples:

Markup Result Markup Result

x over {–x + 1}  
x

−x+1
x over lbrace –x + 1 rbrace  

x
{−x +1}

Scalable brackets
For background, we start with an overview of the matrix command.

Markup Result

matrix { a # b ## c # d } a b
c d

Note
Rows are separated by two # symbols and entries within each row are separated by 
one #.

The first problem people have with matrices is that brackets do not scale with the matrix:

Markup Result

(  matrix { a # b ## c # d }  ) (a b
c d

)

Math provides scalable brackets. That is, the brackets grow in size to match the size of their 
contents. Use the commands left( and right) to make scalable brackets.

Markup Result

left(  matrix { a # b ## c # d }  right) (a b
c d )

Tip Use left[ and right] to obtain square brackets. The list of all available brackets is 
available in the appendix of the Math Guide.

These scalable brackets may also be used with any element, such as a fraction, square root, etc.
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Isolated and unpaired brackets
Math expects that for every opening bracket there will be a closing one. If you forget a bracket, 
Math places an inverted question mark by the corresponding bracket. This disappears when all 
brackets are matched. Sometimes forgetting a bracket causes the whole structure of the formula to
fall apart.

However, an unpaired bracket is sometimes necessary. In such cases, you have two options:

• With non-scalable brackets, use a preceding backslash \ to indicate that the following 
character should not be regarded as a bracket but as a literal character. So the half-open 
interval [a;b[ is represented by \[a;b\[ — try comparing this with [a;b[ 

• Scalable brackets can also be unpaired. The same half-open interval is represented by

    left [ a; b right [ 

For scalable brackets, you can also use the command none to replace a non-existent paired 
bracket.

∣x∣={ x for x≥0
−x for x<0

can be represented by 

abs x = left lbrace stack {x "for" x >= 0 # -x "for" x < 0} right none

Recognizing functions in Math
In the basic installation, Math outputs variables in italics. If you enter a function, Math usually 
recognizes it and outputs it normally (a list of recognized functions is available in the Math Guide). 
If Math fails to recognize a function, you can inform Math about it. Enter the markup code func 
before the function, and the text that follows will be recognized as a function.

Some functions recognized by Math need to be followed by numbers or variables. If these are 
missing, Math puts an inverted red question mark ¿ in their place, which you can only remove by 
correcting the formula: enter a variable or a number, or a pair of empty braces { } as a placeholder.

Tip You can navigate through errors using F3 and Shift+F3.

Equations over more than one line

Suppose you want to make an equation covering more than one line, for example:
x=3
y=1

Your first reaction would be to simply press the Enter key. However, if you press the Enter key, 
although the markup goes to a new line, the resulting equation does not. You must type the 
newline command explicitly. This is illustrated in the table below.

Markup Result

x = 3

y = 1
x=3 y=1

x = 3 newline

y = 1

x=3
y=1

Formula layout 14



Continuing the calculation on a new line without writing a complete new equation is not directly 
possible, because Math expects a term on the left hand side of an equals sign. You can substitute:

• Empty quotes "". This will automatically cause the line to be left-justified.

• Empty braces { }. The following line will then be centered.

• Spaces characters ` or ~. The line will be centered with the spaces.

The alignment of equals signs under each other is described on page 17.

Additionally, spacing between elements in formulas are not set by space characters in the code. 
You need to use special markup to add spaces: ` (grave) for a small space, ~ (tilde) for a large 
space. Another solution would be to add space characters between quotes, to be considered as 
text. Space markup at the end of a formula are ignored by default.

How do I add limits to my sum/integral?
The sum and int commands (see complete list in the appendix of the Math Guide) can (optionally) 
take the parameters from and to. These are used for lower and upper limits respectively. These 
parameters can be used individually or can be combined.

Markup Result

sum from k = 1 to n a_k ∑
k=1

n

ak

int from 0 to x f(t) dt

or 

int_0^x f(t) dt

∫
0

x

f (t )dt  or ∫0

x
f (t )dt

int from Re f ∫
ℜ

f

sum to infinity 2^{-n} ∑
∞

2−n

How do I write a derivative?
Writing derivatives essentially comes down to one trick: Tell LibreOffice it’s a fraction.

In other words, you have to use the over command. Combine this with either the letter d (for a total 
derivative) or the partial command (for a partial derivative) to achieve the effect of a derivative.

Markup Result

{df} over {dx}
df
dx

{partial f} over {partial y}
∂ f
∂ y

{partial^2 f} over {partial t^2}
∂2 f

∂ t 2

Note Notice that we have to use braces (squiggly brackets) to make the derivative.
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To write function names with primes, as is usual in school notation, you must first add the signs to 
the catalog. Using single and double quotes is typographically ugly. See “Customizing the catalog” 
on page 23.

Markup characters as regular characters
Characters that are used for controlling markup cannot be entered directly as normal characters. 
The characters concerned are:  %, {, }, &, |, _, ^ and ". So, for example, you cannot write 2% = 
0.02 or 1" = 2.56cm. Two methods are available to overcome this limitation:

• Use double quotes to mark the character as text, for example 2"%"= 0.02. This is not 
possible for the double-quote character itself.

• Add the character to the catalog. See the section  “Customizing the catalog” on page 23.

In some cases you can use commands. For example:

• lbrace and rbrace give you literal braces {}.

Conversion into a character entity as in HTML or the use of an escape character is not possible in 
Math.

Text in a formula
To include text in a formula, enclose it in straight double-quotes:

abs x = left lbrace matrix {x # "for " x >= 0 ## -x # "for " x < 0} right none

∣x∣={ x for x≥0
−x for x<0

All characters except double quotes are permissible in text. Unfortunately the Special characters 
dialog is not available. If necessary, you can write the text in a text document and copy it into the 
equation editor via the clipboard. In this way smart quotes can be inserted, as shown below.

Figure 12: Smart quotes included by copy and paste from Writer

Text is shown in the font that is selected from the Text list in the Fonts dialog (see “Changing the 
font” on page 18). To select a font for the lower window of the equation editor, set the attribute 
Serif, Sans or Fixed before typing the text.

By default, text is left-justified. You can change the justification with alignc or alignr.

Commands are not interpreted within text. Use quotes to break up the text if you wish to use 
special formatting commands.
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"In " color blue bold "isosceles" " triangles, the base angles are equal"

In isosceles triangles, the base angles are equal

How do I align my equations at the equals sign?
Math does not have a command for aligning equations on a particular character, but you can use a 
matrix to do this, as shown below.

Markup Result

matrix{

   alignr x+y # {}={} # alignl 2 ##

   alignr x   # {}={} # alignl 2-y

}

x+ y = 2
x = 2− y

The empty braces around = are necessary because = is a binary operator and thus needs an 
expression on each side.

You can reduce the spacing around = if you change the inter-column spacing of the matrix:

1) With the equation editor open, choose Format > Spacing from the Menu bar.

2) In the Spacing dialog (Figure 13), click the Category button and select Matrices in the 
drop-down menu.

3) Enter 0% for Column spacing and click OK.

Figure 13: Changing spacing in a formula

Changing the appearance of formulas

Changing the font size
This is one of the most common questions people ask about LibreOffice Math. The answer is 
simple, but not intuitive:

1) Start the formula editor and choose Format > Font size.

2) Select a larger font size under Base size (upper-most entry).
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Figure 14: Edit Base size (top) to make a formula bigger

The result of this change is illustrated in Figure 15.

Figure 15. Result of changing the base font size

Note

The change in font size applies only to the current formula. To change the default 
font size, click on the Default button and then OK. A change in the default font size 
might, for example, make your work easier when you are preparing a big 
presentation and want all the formulas in it to have a base size of 28pt—but do not 
forget to set the font size back to its original value when the work is finished.

Warning: this will modify only the current formula and future formulas you write. To 
modify existing formulas in the document, you need to use a macro (see section 
about macros in the Math Guide).

The size of a subset of characters in a formula may be modified using the size command. For 
example: b size 5{a}  gives the result b a . In the context menu (see Figure 7, above), the 
Attributes listing gives the size command. The value just after size may be absolute (numeric 
value) or relative to the context (base size by default): for example, +6, -3, /2, or *2.

Changing the font
The fonts used in formulas can be changed using Format > Fonts. 

The Formula fonts section of the Fonts dialog (Figure 16) refers to the four specified formula 
elements. The font for operators, relationships and brackets is not affected, as these elements 
normally come from the OpenSymbol font. Similarly elements from the catalog (see “Customizing 
the catalog” on page 23) continue to be displayed in the font specified there.
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Figure 16: Fonts dialog

The Custom fonts section determines which font will be used when the attribute font serif, font 
sans or font fixed is specified.

To change a font, first click on Modify and choose the type of entry you wish to modify. The Fonts 
dialog opens, showing all the fonts available on your system.

Figure 17: Font modification dialog

The Font text input box uses predictive text as you type to assist locating the wanted font. If you do
not know its name, use the scrollbar to scroll through them. Click on any name and the preview 
box will show a sample.

Variables should be written in italics, so make sure that the Italic box is checked. For all other 
elements, use the basic (Roman) form. The style can be easily altered in the formula itself by using
the commands italic or bold to set these characteristics and nitalic or nbold to unset 
them.

When you have chosen a new font for a formula, the old font remains in the list alongside the new 
one and can be selected again. This applies only to the current session; the old font is not stored 
permanently.

You can choose any fonts from the list, but if you are exchanging documents with someone else, 
you should choose fonts that are present on your colleague’s computer.
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Changing the color
Use the command color to change the color of a subset of a formula: color red ABC gives
ABC . Choose from 8 colors: white, black, cyan, magenta, red, blue, green, yellow.

You may set a color for a subset of a formula if it is enclosed between { } or other parentheses. 
For instance: A B color green {C D} E gives AB C D E .

Color commands can be nested in subsets of formulas as shown in this example : color blue 
{A B color yellow C D} gives AB C D . The space between C and D limits the color to the 
variable following the command.

It is not possible to select a background color: it is always transparent in Math. The background 
color of the whole formula is then the same as the background of the document or frame (in a text 
document for instance). In Writer, you can use object properties (right-click the formula Object) to 
choose a background color for the whole formula (see “Background, borders, and size” on page
22).

Formulas in Writer documents

Numbering equations
Equation numbering is one of Writer’s best hidden features. The steps are simple, but obscure:

1) Start a new line.

2) Type fn and then press F3. Note this is NOT the keyboard Fn key.

The fn is replaced by a numbered formula:

E=mc 2 (2)

Now you can double-click on the formula to edit it. Click in any blank space within the document to 
revert to standard Writer menu. Click again to deselect the formula.

You can insert a cross-reference to an equation (for example “as shown in Equation (2)”) as 
follows:

1) Choose Insert > Cross-reference from the Menu bar.

2) On the Cross-references tab (Figure 18), under Type, select Text.

3) Under Selection, select the equation number. 

4) Under Insert reference to, select Reference.

5) Click Insert.

If you later add more equations in a position above the referenced equation, all the equations will 
automatically renumber and the cross-references will update.

Tip
To insert the equation number in the cross-reference without parentheses around it, 
choose Numbering instead of Reference under Insert reference to.

The AutoText inserted as a result of the above procedure consists of a 1x2 table. The left cell 
contains the formula and the right one the number. The number is an automatic counter named 
Text. You can edit the AutoText if, for example, you prefer square rather than round brackets, or if 
you want formula and number to be separated by tabs rather than formatted as a table. For more 
information, read the section on “Using AutoText” in Chapter 3 (Working with Text) in the Writer 
Guide.
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Figure 18: Inserting a cross-reference to an equation number

Position
Normally a formula is anchored As character in a Writer document. But as with any other OLE 
object, you can change the anchoring mode to position the formula where you want it. For more 
information, see Chapter 11 (Graphics, the Gallery, and Fontwork) of this guide.

By default, formula objects anchored As character are automatically aligned vertically to the 
baseline of the surrounding text. To align the formula manually, go to Tools > Options > 
LibreOffice Writer > Formatting Aids and uncheck the option Math baseline alignment. This 
setting is stored with the document and applies to all formulas within it. New documents use the 
current setting from this dialog.

Margins
An inserted Math object has margins to left and right of it, separating it from surrounding text. If you
do not want this, it is best to alter the frame style for formulas, as this will apply simultaneously to 
all existing formulas and those still to be inserted in the document. Proceed as follows:

1) Press F11. The Styles and Formatting dialog opens.

2) Click on the Frame Styles icon.

3) Find the Formula frame style and right-click on it.

4) Choose Modify from the context menu. The Frame Style dialog opens.

5) Switch to the Wrap tab of the dialog. Change the values for Left and Right in the Spacing 
section to 0.00.

6) Click OK to close the dialog.

Formulas in Writer documents 21



This changes the spacing for all formulas that have not had their spacing adjusted manually. You 
can find more information on using styles in “Default layout with style” on page 25 and in Chapter 3
(Using Styles and Templates) of this guide.

Text mode
Larger formulas should always be in a paragraph of their own, separated from the text. When you 
use formula elements in running text, they can often be higher than the letter height.

However, if it is necessary to place a formula within running text, switch into the equation editor 
and go to Format > Text mode. Math will try to shrink the formula to fit the letter height. The 
numerators and denominators of fractions are shrunk, and the limits of integrals and sums are 
placed beside the integral/sum sign.

Example:
A formula in a separate paragraph:

∑
i=2

5

i2

and the same formula embedded in text mode: ∑i=2
5 i2

Background, borders, and size
With regard to formatting, formulas are treated as objects of the Frame Style type with the Formula
frame style. Background color and borders can be set using this style or directly with Format > 
Frame/Object, or by right-clicking the formula and choosing Object from the context menu. In the 
default installation, formulas have a transparent background and no borders. The size of a formula 
cannot be adjusted; in a Writer document it depends directly on the way the formula is constructed 
(see “Changing the font size” on page 17).

Creating a formula library
When you use the Math component of LibreOffice directly from the Start Center or with File > New 
> Formula, you create documents with the file suffix ODF, each containing a single formula. You 
can use these to build up a library of frequently-used formulas. Embedded formulas can also be 
stored as separate Math documents by right-clicking on the formula and choosing Save copy as 
from the context menu. To insert such a Math document into a Writer document, use Insert > 
Object > OLE Object. Select the option Create from file and enter the path name of the file or 
browse for it using your system’s file manager by pressing the Search button.

Note
You cannot insert the document by dragging and dropping with the mouse, nor by 
using Insert > File.

Formulas cannot be stored in the gallery because they are not in graphical format. You can 
however store a formula as AutoText. Write the formula in a separate paragraph, select it and go to
Edit > AutoText. For further information see “Using AutoText” in Chapter 3 (Working with Text) in 
the Writer Guide.

Fast insertion of formulas
If you already know the markup of your formula, here is a faster method to build your formula:

• Write the formula markup in Writer.
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• Select the markup.

• Insert the formula using a toolbar button, a menu item, or a keyboard shortcut.

This method avoids the need to open and close the Math window and thus saves time.

Customizations

Customizing the catalog
If you need to use a symbol that is not available in Math, you can add it to the catalog yourself. The
following example shows the procedure for symbols that are used in marking school work.

1) Go to Tools > Catalog or click on the catalog button  to open the Symbols catalog 
(Figure 8).

2) Click the Edit button. The Edit symbols dialog (Figure 19) opens.

3) The symbols are arranged in symbol sets. In the lower part of the window, choose an 
available set for your new symbol from the Symbol set list, for example the Special set. Or 
you can type the name of a new symbol set directly into the box.

4) From the Font list, choose a font that contains the desired symbol.

When you have selected a font, its characters appear in the font summary window. You can
scroll through it using the scrollbar at the side, or use the Subset list to go straight to the 
place you need.

To follow this example, choose the font DejaVu Sans and the subset General punctuation.

5) Click on the desired symbol (here Ux2032). It appears enlarged in the right-hand preview 
box (see Figure 20). Make sure that the symbol set is set to Special.

6) In the Symbol field, enter a name for the symbol, for example prime.

7) If the name is not already in use, the Add button becomes active. Click on it.

8) You can immediately add more symbols. In the example, the “U+2033” symbol, named 
dblprime, and the “U+2034” symbol, named triprime, are added (see Figure 21).

9) Click OK to close the dialog.

Figure 19: Edit Symbols dialog
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Figure 20: Edit Symbols dialog: characters selected

Now the Symbol set view area shows the new symbol. It can be selected just like the other 
symbols, either from here, or by writing them directly into the equation editor in the form %prime.

Caution
Symbols (Greek or Special), in contrast to commands, are case sensitive 
(lowercase/uppercase). 

Numerous free fonts contain a great number of mathematical symbols. The “STIX1” font is worthy 
of special mention here. It was developed specially for writing mathematical/technical texts. The 
DejaVu2 and Lucida3 fonts also have a wide range of symbols.

Figure 21: Catalog with new symbol

Note
Many symbols occur in more than one font. If you want to exchange documents with 
others, take care to use a font that is installed on their machine.

In the default LibreOffice installation, only those user-defined symbols that actually occur in the 
document are stored with it. Sometimes it is useful to embed all the user-defined symbols, for 
example when the document is going to be further edited by another person. Go to Tools > 
Options > LibreOffice Math and on the Settings page, uncheck the option Embed only used 
symbols (smaller file size).This setting is only available when you are working on a Math 
document.

1 Font files for STIX are available from http://www.stixfonts.org 
2 Font files for DejaVu Sans are available from http://www.dejavu-fonts.org 
3 Lucida Sans belongs to the JRE package, which is probably already on your computer.
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Default layout with style
In Writer, formulas are formatted according to the Formula
frame style. In the Style and Formatting window (displayed
with F11), click on the third icon at the top: Frame Styles.
Right-click on Formula and select Modify. By this means,
you can directly modify all formulas in your document, with
regard to spacing (page 21) or background (page 22),
unless you manually modify formula formatting.

To apply this style in all your new Writer documents, you
must include the Formula style in your default template. To
do so, create a new Writer document and modify the 
Formula frame style as you wish. Save the document using 
File > Save as Template and save it into My Templates
with a name of your choice. To define this template as your default template, select the template 
you just created and choose Set as default. If you wish to return to the default template given at 
installation, open the Template Manager (File > Templates > Manage), click on the Action Menu 
and point to Reset Default Template, on the drop-down menu, and click Text Document. This 
menu choice does not appear unless a custom template has been set as the default.

The next time that you create a document by choosing File > New, the document will be created 
from the new default template.

For more information on the Template Manager, see Chapter 9, Styles and Templates.

Application to chemical formulas
Math was designed to build mathematical formulas, but it can also be used to write chemical 
formulas. In chemistry, formulas look like H2O: names are usually non-italic uppercase. To write 
chemical formulas with Math, deselect the Italic attribute in the Fonts dialog (see “Changing the 
font” on page 18).

Here some examples of chemical formulas:

Construction Example Entry

Molecules H2 SO4 H_2 SO_4 (please note the space!)

Isotopes U92
238 U lsub 92 lsup 238

Ions SO4
2− SO_4^{2-{}} or SO_4^{2"-"}

Notes: lsub or lsup are abbreviations for left subscript and left superscript. Empty braces after 
2- are necessary to avoid errors as there is no right member after the minus sign.

For reversible reactions, there is no satisfactory double arrow in Math. If you have a font with a 
suitable symbol, you may use the method described in “Customizing the catalog” on page 23. For 
instance, DejaVu fonts have these double arrows ⇄ ⇆ ⇋ ⇌.

Alternatively, if you find a special character in a document you can copy it, for example here in this 
formula: C+O⇌ CO  "⇌". Other double arrows can be found here:
http://dev.w3.org/html5/html-author/charref from character x021C4, or here: 
http://www.unicode.org/charts/PDF/U2190.pdf, which is a subset of this location: 
http://www.unicode.org/charts/#symbols
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Math commands – Reference

The complete list of commands and reserved words used by Math is available in the Math Guide:

• Unary / binary operators

• Relations

• Set operations

• Functions

• Operators

• Attributes

• Brackets

• Formats

• Others

• Characters – Greek

• Characters – Special

• Reserved words in alphabetic order
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